Problem z maskami uprawnień 1922 4

O temacie

Autor inż. Avallach

Zaczęty 31.12.2010 roku

Wyświetleń 1922

Odpowiedzi 4

inż. Avallach

inż. Avallach

Administrator
posty7662
Propsy5238
NagrodyV
ProfesjaProgramista
  • Administrator

inż. Avallach
Administrator

Problem z maskami uprawnień
2010-12-31, 11:43(Ostatnia zmiana: 2010-12-31, 11:54)
Mniej więcej wczoraj stało się coś dziwnego z maskami uprawnień, wygląda na błąd w bazie danych. Nie wiem jak bardzo jet rozległy, ale wygląda na to że część grup ma w różnych miejscach "pourywane" dostępy. Ciągną się normalnie do pewnego momentu, a potem wszędzie pusto, brak dostępu. W przypadku administratorów maska jest "postrzępiona", czyli czasami już nie mogą np wyświetlać tematów ale jeszcze długo ciągnie się pozwolenie odpisywania albo uploadowania plików itd. Ogólnie problemy zaczynają się w połowie archiwum tajnych działów i ciągną do samego końca. Kiedy próbuję założyć nową maskę z maksymalnymi uprawnieniami, ucinają się one równo, w połowie tajnego działu NT (przez równo mam na myśli że dalej jest zero na wszystkich czynnościach, czyli ani czytania, ani wyświetlania, ani uploadowania, ani pisania itd).
Problem jest tym poważniejszy że nie da się go naprawić przez edycję maski, cokolwiek by się wpisało od pewnego momentu zawsze są same zera. Będziemy starali się to naprawić, ale wydaje mi się że najlepszym rozwiązaniem będzie częściowe przywrócenie backupu bazy danych z momentu kiedy wszystko było ok. Tymczasowo żeby zorientować się jak duża jest skala problemu, prosiłbym o pisanie tutaj jeśli ktoś ma problemy z wykonywaniem jakiejkolwiek czynności którą normalnie powinien móc wykonywać.

Aha, admini nie muszą odpisywać, jak tutaj ma się sprawa wiem aż za dobrze :lol:

//edit: No i problemy nie muszą być od razu zauważone, bo użytkownicy którzy jakieś maski mają, to nieraz po kilka, więc mogą nawzajem "zasłaniać" swoje dziury.

//edit2: Jest jeszcze taki problem, że jak już komuś całkiem nawaliły maski to w ogóle nie zobaczy tego tematu :lol:

inż. Avallach

inż. Avallach

Administrator
posty7662
Propsy5238
NagrodyV
ProfesjaProgramista
  • Administrator

inż. Avallach
Administrator

Problem z maskami uprawnień
#1 2011-01-15, 22:27(Ostatnia zmiana: 2011-01-15, 22:30)
Cóż, po długich machinacjach udało się zrobić backup bazy danych, przelecieć tabelkę odpowiedzialną za maski uprawnień narzędziami diagnostycznymi a wreszcie odtwarzać ręcznie i... nic nie pomogło. Potem postanowiliśmy zupdate'ować oprogramowanie co... także nie przyniosło skutku. Na szczęście dzielny Zdunek w końcu prawdopodobnie odnalazł przyczynę:
Cytuj
22:21:28 Zdunek
zostawiamy całą sprawę do poniedziałku
chyba mam winowajcę
 
22:21:34 Avallach
?
ale to nie ja? :D  
 
22:21:57 Zdunek
nie
 
22:22:02 Avallach
a co?
 
22:22:09 Zdunek
active24 mają chujowo skonfigurowany serwer :D
Tak więc nie lękajcie się i bądźcie dobrej nadziei.

Buła

Buła

Użytkownicy
wyłącz komputer i wyjdź z domu
posty2402
Propsy3163
NagrodyV
Profesjabrak
  • Użytkownicy
  • wyłącz komputer i wyjdź z domu
 

Wowoz

Wowoz

Użytkownicy
Wowoźny
posty3699
Propsy4862
NagrodyVV
Profesjabrak
  • Użytkownicy
  • Wowoźny
przelecieć tabelkę

:pokerface:





Sam bym mógł to zrobić :lol:
Czyli co było nie tak wkońcu? Tabelki?
 

Buła

Buła

Użytkownicy
wyłącz komputer i wyjdź z domu
posty2402
Propsy3163
NagrodyV
Profesjabrak
  • Użytkownicy
  • wyłącz komputer i wyjdź z domu
To, że właściwie od początku forum robiliśmy takie sajgon w maskach, że to jest aż nieprawdopodobne :lol:
Dziwie się, że to się wcześniej nie zjebało.
 


0 użytkowników i 1 Gość przegląda ten wątek.
0 użytkowników
Do góry