Brak animacji przy nowym dodanym obiekcie animowanym. 338 3

O temacie

Autor Pan.L

Zaczęty 18.06.2016 roku

Wyświetleń 338

Odpowiedzi 3

Pan.L

Pan.L

Użytkownicy
posty65
Propsy2
Profesjabrak
  • Użytkownicy
Zatem mój problem polega na tym że po wstawieniu do gry nowego obiektu animowanego w grze postać zamiast wykonać animacje to on przemieszcza się przed obiekt i nic nie wykonuje a stoi. Czym to może być spowodowane ?
 

Mark56

Mark56

Moderator
som veľký magič
posty1594
Propsy1726
ProfesjaAnimator
  • Moderator
  • som veľký magič
Dodałeś animacje używania tego objektu do humans.mds ? 
Nazwałeś je poprawnie ? (objekt animowany CHAIR_NORMAL.MDS wymaga animacji o nazwach CHAIR w humans.mds jako przykład )
Jak używasz G2 to trzeba skompilować humans.mds na nowo (zrobisz tak usunięciem humans.msb z anims/compiled ).
 


Pan.L

Pan.L

Użytkownicy
posty65
Propsy2
Profesjabrak
  • Użytkownicy
Odświeżam ten zakurzony temat. Nie miałem zbytnio czasu się w to bawić a nawet z zapału się wypaliłem jednak ostatecznie powracam. Wszystkie animacje posiadam są dobrze nazwane jednak zapewne nie są wpisane do humans.mds. Wszedłem w ten plik i jeśli mam być szczery nie wiem jak dopisać mój animowany obiekt. Jakieś rady na którym się wzorować lub jakiś poradnik który mi umknął ?
-------------------------------------------------------------------------------------------------------------------------
Znalazłem ten o to przykładowy skrypt do humans.mds z Woga jednak nie jestem pewny czy na jego podstawie mogę wykonać swój i nie do końca umiem go odczytać

ani ("t_CAMPFIRE_Stand_2_S0" 1 "s_CAMPFIRE_S0" 0.1 0.0 M. "HUM_CAMPFIRE.asc" F 0 83)

ani ("s_CAMPFIRE_S0" 1 "s_CAMPFIRE_S0" 0.0 0.0 M. "HUM_CAMPFIRE.asc" F 83 83)
ani ("t_CAMPFIRE_S0_2_Stand" 1 "" 0.0 0.1 M. "HUM_CAMPFIRE.asc" R 0 83)

ani ("t_CAMPFIRE_S0_2_S1" 1 "s_CAMPFIRE_S1" 0.0 0.0 M. "HUM_CAMPFIRE.asc" F 83 177)
{
*eventTag (102 "DEF_INSERT_ITEM" "ZS_LEFTHAND")
*eventTag (102 "DEF_CREATE_ITEM" "ZS_RIGHTHAND" "CA_ITMI_BRANCH")
}

ani ("s_CAMPFIRE_S1" 1 "s_CAMPFIRE_S1" 0.0 0.0 M. "HUM_CAMPFIRE.asc" F 178 220)
{
*eventSFX (36 "PAN_FRYING" R:1000 EMPTY_SLOT )
}
ani ("t_CAMPFIRE_S1_2_S0" 1 "s_CAMPFIRE_S0" 0.0 0.0 M. "HUM_CAMPFIRE.asc" R 83 177)
//{
// *eventTag (101 "DEF_DESTROY_ITEM")
//}
{
*eventTag (175 "DEF_EXCHANGE_ITEM" "ZS_LEFTHAND" "ItFoMutton")
*eventTag (101 "DEF_REMOVE_ITEM")
}


----------------------------------------------------------------------------------------------------------------------------Znalazłem poradnik o tym na forum.. Jeśli będę miał jakiś problem to napisze :P
 

Mark56

Mark56

Moderator
som veľký magič
posty1594
Propsy1726
ProfesjaAnimator
  • Moderator
  • som veľký magič
Po prostu zrób copy paste do humans.mds .... potem usun skompilowane pliki
 



0 użytkowników i 1 Gość przegląda ten wątek.
0 użytkowników
Do góry